Rote Kästchen statt Schrift

Alles was mit Typografie, Schriften und Texten zu tun hat.
stirnlappenbasilisk
Beiträge: 7
Registriert: So 19. Okt 2014, 00:25

Rote Kästchen statt Schrift

Beitrag von stirnlappenbasilisk » So 19. Okt 2014, 00:36

Hallo, hallo!

Also ich bin neu hier und habe auch Scribus noch nicht lange, aber schon tut sich ein Problem auf:
Bei einigen Schriftarten, hauptsächlich den Symbol-Schriftarten, aber auch anderen, erscheinen nur Rote Kästchen statt Schrift. Ich weiß, dass das heißt, dass das Zeichen nicht gefunden wurde, aber mehr auch nicht.
Ich möchte dieses Problem gerne beheben, weiß aber nicht wie.
Bei einer Schriftart, die ich mir runtergeladen und installiert habe, zeigt es z.B. Zahlen problemlos an, die Buchstaben aber nicht...

Ich verwende Scribus 1.4.0 unter Ubuntu 12.04 LTS (32-bit) - Scribus ist auch die 32bit - Version.

Ich hoffe, hier kann mir jemand auf verständliche Weise helfen. Ich denke nämlich, ich habe das Problem schon in englischsprachigen Foren gefunden, verstehe aber kein Wort von dem, was da steht - obwohl ich dieser Sprache theoretisch mächtig bin. Deswegen zur Information: Ich bin ein Linux-Noob und fühle mich schon ziemlich Hacker-mäßig, sobald die Kommandozeile offen ist :D

Also vielen Dank schonmal im Voraus und ein schönes Wochenende allen!

stirnlappenbasilisk
Beiträge: 7
Registriert: So 19. Okt 2014, 00:25

Re: Rote Kästchen statt Schrift

Beitrag von stirnlappenbasilisk » So 19. Okt 2014, 01:00

Habe mittlerweile rausgefunden, dass es wohl teilweise am true type liegt. Eine runtergeladene otf funktioniert einwandfrei. Aber man muss doch auch die ttf - Dinger zum Laufen kriegen. Nur wie?

stirnlappenbasilisk
Beiträge: 7
Registriert: So 19. Okt 2014, 00:25

Re: Rote Kästchen statt Schrift

Beitrag von stirnlappenbasilisk » Mo 20. Okt 2014, 15:03

Hat denn keiner das gleiche Problem gehabt und gelöst? Braucht ihr noch mehr Infos? Nur am ttf Format kann es ja auch nicht liegen, denn Arial als ttf funktioniert auch einwandfrei.
-.-"

Benutzeravatar
utnik
Beiträge: 333
Registriert: Mo 14. Okt 2013, 05:48

Re: Rote Kästchen statt Schrift

Beitrag von utnik » Mo 20. Okt 2014, 15:47

hallo stirnlappenbasilisk

ohne die datei zu sehen lässt sich das problem schlecht lösen.
wenn du mir dein projekt zeigst ('datei' → 'für ausgabe sammeln' und dort unbedingt auch die schriften anwählen…) sehe ich mir das gerne an.

gruss
utnik

Benutzeravatar
Lehrerin
Beiträge: 175
Registriert: Do 17. Okt 2013, 22:09
Kontaktdaten:

Re: Rote Kästchen statt Schrift

Beitrag von Lehrerin » Mo 20. Okt 2014, 18:10

hallo stirnlappenbasilisk,

viele Zeichensätze haben nicht alle Zeichen. Diejenigen Zeichen, die es in dem einen Zeichensatz (z. B. Garamond) gibt, in einem anderen aber nicht, werden dort dann als rote Kästchen dargestellt. Mit TTF oder OTF hat das nichts zu tun. So haben z. B. viele amerikanische Zeichensätze kein € -Zeichen und keinen § . Das gilt nicht nur für das Zeichen selbst, sondern auch für Schnitte. Wenn du z.B. "Semibold" angegeben hast, der Zeichensatz aber keinen Schnitt Semibold hat, dann erscheint alles rot. Die einfachste Lösung ist, mit Absatzstilen zu arbeiten, dann bekommst du immer die vorhandenen Fonts und Schnitte angezeigt und kannst nichts anwählen, was es nicht gibt.
Bei Sonderzeichen muss man sich den gesamten Zeichensatz ansehen, um feststellen zu können, welche Zeichen es gibt.

Gruß
Lehrerin

Benutzeravatar
Arran
Beiträge: 244
Registriert: Mo 14. Okt 2013, 15:43
Wohnort: Isle of Arran, Scotland
Kontaktdaten:

Re: Rote Kästchen statt Schrift

Beitrag von Arran » Mo 20. Okt 2014, 18:25

Darf ich davon ausgehen, dass es sich um einen frei verfügbaren Font handelt? Dann setze entweder einen Link zum Download hier ein oder noch besser ist es, wenn du Deinen Font komprimierst und dann hier als Dateianhang einstellst. Sollte es sich um eine gekopirechtete Schrift handeln, dann müsstest Du mir die Datei lieber per Email zuschicken. Emailadresse: fonts@wossc.org. ich verspreche hoch und heilig, die Schrift gleich nach der Lösung wieder zu löschen.

stirnlappenbasilisk
Beiträge: 7
Registriert: So 19. Okt 2014, 00:25

Re: Rote Kästchen statt Schrift

Beitrag von stirnlappenbasilisk » Mo 20. Okt 2014, 19:36

Erstmal vielen Dank für die Antworten!

Ein Problem habe ich gerade selber gelöst -.-" Bei dieser Schriftart: http://www.dafont.com/la-truite-a-papa.font funktioniert nun alles einwandfrei, da ich erkannt habe, dass sie nur Großbuchstaben nimmt (ich dachte, die wandelt mir die kleinbuchstaben automatisch (in Kapitälchen vielleicht) um, macht sie aber nicht.)

Aber nichtsdestotrotz: auch einige vorinstallierte Schriftarten gehen nicht, auch wenn das hauptsächlich Symbol/fremde Schriftzeichen-Schriftarten sind, wie:
Dingbats, Kacst, Khmer, Mallige, Open Symbol, Standard Symbol L, Symbol, Vemana2000, Webdings u.a. (einige hab ich mal rausgelassen)

Also...ja...was nun?

Bringt es was, wenn ich ne Beispieltext-Datei mit z.B. Wingdings hier hochlade?

Benutzeravatar
utnik
Beiträge: 333
Registriert: Mo 14. Okt 2013, 05:48

Re: Rote Kästchen statt Schrift

Beitrag von utnik » Di 21. Okt 2014, 00:25

stirnlappenbasilisk hat geschrieben:Bringt es was, wenn ich ne Beispieltext-Datei mit z.B. Wingdings hier hochlade?
ja, das könnte durchaus was bringen. (die datei natürlich zusammen mit dem von dir verwendeten wingdings-font…)

gruss
utnik

Benutzeravatar
Arran
Beiträge: 244
Registriert: Mo 14. Okt 2013, 15:43
Wohnort: Isle of Arran, Scotland
Kontaktdaten:

Re: Rote Kästchen statt Schrift

Beitrag von Arran » Di 21. Okt 2014, 00:46

Installiere Dir mal aus den Repos FontForge, dann kannst Du die in Frage stehenden Schriften genau analysieren. Wenn in den ersten paar Zeilen in den rot durchkreuzten Feldern keine Glyphen sind, gibt es die bei dieser Schrift nicht.
Da ich bereits beim Einrichten einer neuen Version zuerst mal die meisten Schriften schon mal lösche, inklusiver aller Fremdalphabet-Schriften, und mir dann meine üblichen etwa 100 Fonts in die korrekten Order kopiere habe ich so nie Schwierigkeiten.

Im ersten Beitrag hast du auf ein englischsprachiges Forum mit «Lösungen» erwähnt. Es wäre positiv, jeweils gleich darauf zu verlinken.

stirnlappenbasilisk
Beiträge: 7
Registriert: So 19. Okt 2014, 00:25

Re: Rote Kästchen statt Schrift

Beitrag von stirnlappenbasilisk » Di 21. Okt 2014, 19:10

Also, ich weiß nicht mal sicher, ob das in dem englischsprachigen Forum überhaupt mein Problem behandelt, und ich find es jetzt auf die Schnelle nicht wieder.
Aber ich wollte jetzt hier mal ein Dokument mit nem Beispieltext in Dingbats hochladen, plus die Schriftart und sicherheitshalber noch die zwei Dateien, die außerdem in dem Ordner sind und die ich nicht zuordnen kann, ABER das geht nicht. Also die eine Datei ist jetzt im Anhang, ansonsten hätte man noch arial.ttf, aber die macht ja keine Probleme, die anderen drei Dokumente haben nicht erlaubte Dateiendungen. Die Dingbats-Schrift endet auf .pfb, die anderen beiden Dateien auf .pfm und .afm. Wobei bei der Datei mit .afm ein 'A' auf einem Blatt als Thumbnail angezeigt wird: Könnte das schon ein Hinweis auf die Lösung meines Problems sein?

Vielen Dank.
Dateianhänge
Dokument-1.sla.gz
(3.71 KiB) 250-mal heruntergeladen

Antworten